
Animating a Paddle and Ball in Blender 

 
When you first open Blender, there are lot of features that are turned off by default. These are called add-ons. You can 
think of them as plugins as well. 

 
Settings and Navigation 

• First, we’re going to go to our settings to change our default click to left-click instead of right-click 
o File > User Preferences 

▪ Go to the Input tab and on the left where it says Select With, change it to Left 
• Additionally, under the Input tab > 3D View > 3D View (Global) > Set 3D Cursor 

o Make sure it says Mouse 
o Click the drop-down and make sure it says Action and Double Click 

▪ This requires a double-click to change our cursor location 
• It’s really finicky and you can accidentally move it all the time so this is a provision to 

prevent that 
• Go to File > User Preferences… > Add-ons tab 

o Make sure “Mesh: LoopTools”, “Dynamic Context Menu” and “Pie Menu: UI Pie Menu Official” is 
checked 

• Click Save User Settings at the bottom and close your window by hitting the “X” 
• Render Engine 

o The default render engine is Blender Render 
▪ This render engine has the Freestyle feature which has the toon shading that we will be working 

with today 
• Opening up Blender 

o When you open up Blender, this is the typical scene you see 
▪ A cube, a camera and a light 

• We’re going to delete our cube so click on the cube and hit “X” 
o Press Delete 

• Our navigation keys that help us move around our viewport center around the middle mouse button 
o Orbit - middle-mouse button (if middle-mouse button doesn’t work, try left click) 
o Pan - Shift + middle-mouse button 
o Zoom - Ctrl + middle mouse button (move your mouse up and down) 

• Transformation Tools 
o We can create a quick shape in order to play around with our transformation tools 
o On the left, you can go to the Create menu and click one the shapes 
o Translate moves the shape 
o Rotate rotates the shape 
o Scale makes the shape bigger and smaller 
o Pressing X, Y, or Z after activating a transformation allows you to transform in only one direction 
o You can press Esc or right-click to not translate, rotate or scale 

• X is delete 
• Modeling the Paddle Face 

o Anything with your view is on the bottom; we’re going to go into our top view 

 
▪ You can to where it says View at the bottom and choose the Top view; you can also use number 

pad 7 as a shortcut 
o We’re going to add a new object 

▪ Press Shift + C to move our red and white circle to the origin 
▪ You can go to Add at the bottom or you can press Shift + A 

• We’re going to Mesh > Circle 
▪ Click your numpad “.” to zoom into the circle 

o On the left we have some options pop up so we can manipulate our object 
▪ Once we go into “Edit Mode” the options disappear 



▪ Type “62” for Vertices 
o Click “Tab” and go to “Edit Mode” 

▪ Now we can see all our vertices 

 
o Vertically, we have our vertices on the axis, but you want the axis to be in the middle like it is on the X 

axis 
▪ We’re going to press “R” to rotate our circle, type 90 on your numpad and hit enter and your 

circle should be rotated 90 degrees 
• So now the vertices should be sitting on the X-Axis 

o We’re going to go to Edge mode; at the bottom you can go back and forth from point to edge to face; 
you can also use the shortcut (Ctrl/Cmd + Tab) 

o Right-click on your top and bottom edge, then hit “X” 
▪ Select Edge to delete 

 
o We’re going to go back to Vertex mode (Ctrl/Cmd + Tab > Edge) and press “A” to select all our vertices 
o We’re going to bridge our vertices 

▪ You can either go over to the left and scroll down to the Loop Tools we activated and click 
Bridge from there; you can also press the spacer to reach the Dynamic Context Menu we 
activated and search for “Bridge” and select “Bridge/Loft” 

o We’re going to scale it up a bit vertically 
▪ Press “S” for Scale and “Y” to isolate the scale on the Y-Axis 
▪ On the bottom left, it shows you how much you’re scaling it up; we’re going to go up to about 

1.06 
o Let’s right-click our two vertices on the bottom 

▪ Press “O” to activate proportional editing 
▪ Press “S” to Scale 
▪ We can control the circle that pops up with the middle mouse button 

• Change the proportional size to 1.61 with your scroll wheel and change the scale to 1.12 
• Then change the proportional size to 1.46 and change the scale to 1.16 
• This gives us a wider bottom 

• Modeling the Paddle Handle 
o With our vertices still selected, we’re going to press “X” and delete vertices 
o Let’s switch to Edge mode and select (right-click) the bottom edge 
o We’re going to Extrude our edge 

▪ We can either go to the bottom to Mesh > Extrude > Edges Only or we can just press “E” 
▪ It’s initially going all over the place, but we can lock in an axis by pressing “Y” 
▪ Take it down to about -1 (look at the bottom left) 

o We’re going to scale it up, but we have to turn off Proportional Editing so press “O” to deactivate 
▪ Press “S” for Scale and scale it up to 1.20 



o We’re going to add some edges to our handle 
▪ Hit “Ctrl + R” 

• You’ll see a pink line that indicates where we’re going to add our cut 
• Use your scroll wheel to increase your cuts (scroll up 9 times) 

o Stop at 10 lines and click twice 
• If you mess up, you can adjust it on the left under “Loop Cut and Slide” 

o With our middle mouse button, we’re going to move it up and change our orthographic view to 
perspective 

o Go to Face mode and hit “A” to select all our faces 
o Press “E” to Extrude and type “.13” on your numpad and press “Enter” 
o Let’s hit “Tab” and go back to Object mode 
o Our object is a little faceted; to smooth it out, go over to the left and on the Tools tab under Shading, 

click Smooth 
▪ It washes out our edges, so to fix that, on the right, click the wrench and add the “Edge Split” 

modifier 
• Creating Materials 

o We’re now are going to create the materials for our paddle 
o We want to split our view in half, so go to the top right corner with the diagonal lines and move it to the 

left 

 
▪ PLEASE, be careful with this because you can easily create a bunch of views or tools sets that 

you don’t want 
o In the lower left, click the cube and change the view to UV/Image Editor 



 
▪ We’re going to click the file folder and bring in a jpeg called “COLORS” 

• The top color is for the ball 
• The four in the middle are for the paddle 
• The last two are for the background 

o To create a new material, we’re going to click on the ball with the checkerboard on it 

 
▪ Click “New” 
▪ Under Shading, check “Shadeless” 
▪ Click the white box under Diffuse and then click the eyedropper 
▪ Hover over the top color and click 
▪ Double-click Material.001 and change it to “yellow” 
▪ Click the “+” to add a new material and click “New” 
▪ Check “Shadeless” under Shading 
▪ Click the white box under Diffuse, the eyedropper and then select the orange color 
▪ Repeat the process for the rest of the colors 

• Salmon/Pink/Red 
• White/Eggshell 
• Green/Teal/Blue 

o We can now merge our screens together, so on the paddle view, click the diagonal lines in the upper 
right corner, hold down and drag to the right 

▪ You should see a faint arrow; let go when you see this 
• Texturing the Paddle 

o Press “Tab” and go into Edit mode 
o Now we can add our materials to specific components 
o We’re going to click “numpad 5” to go into orthographic view and “numpad 7” to go to the top view 



o Press “A” to deselect everything 
o We want to go into Wireframe mode so that when we select our faces, the ones on the bottom are 

selected as well 
o Press “Z” and choose “Wireframe” 
o Press “B” for box select 

▪ We’re going to select these faces 
• The black boxes are what you have to include to select the faces, so make sure to put 

your selection box above the black box of the 3rd face level 
o Press “Z” again and go into Material mode 
o We’re going to select the orange color and click “Assign” 

▪ We can middle click and drag up to make sure the material was applied on all sides 
o Now on the face of the paddle, we’re going to select (right-click) the face closest to the orange color and 

the Ctrl + select the face on the top and all of the faces in between will be selected 
▪ The top face will still look yellow, but it is selected 
▪ You can tell by its edge being orange; if the edge is black, then it’s not selected 
▪ We’re going to assign salmon (or red or pink) to this section 

o On the side of the paddle we’re to right-click and Ctrl + right-click all the way around the paddle until we 
have them all selected 

▪ If we try to Ctrl + click, one side to the other, it’ll take the shortest path and not click the faces 
we want 

▪ We’re going to assign white to this section 
o We’re going to make the bottom teal 

▪ Rotate your view to the bottom of the paddle 
▪ Right-click and then Ctrl + right-click to select the bottom faces 
▪ Assign the teal 

o Now we have a material on our object 
o Hit “numpad 5” to go into perspective mode 
o Press “Tab” and go into object mode 

• Setting Up Freestyle (Toon Shading) 
o On the right, click on the camera to go back to the Render tools 

 
o If you click and hold then drag down, you can close all of the open tabs 
o Check “Freestyle” 
o Press “Shift + Z” to see the live render 
o On the right, click on the Freestyle dropdown 

▪ Change the Line Thickness to 1.2 
▪ This may seem thin now, but it’ll be good for our project later 

o Next to the camera, there is an icon with pictures; this is the render layers; click this 

 
▪ Click and drag down to collapse all of the tabs 

o Under Freestyle Line Set 
▪ Under Edge Types, check Material Boundary 

• Rigging the Paddle 
o Shift + Z to go back to our normal view 
o To rig our paddle, we’re going to add a bend modifier 
o On the right, click on the wrench for the Object modifiers 

 
▪ Click on Add Modifier and select Simple Deform 

o Right away you can notice some craziness going on because we’re on the Twist tab 
▪ Switch to the Bend tab 

o Click the eye on our modifier to disable it temporarily 
o Press “Tab” and go into Edit mode 



o In Blender, wherever the cursor is (red and white circle), that’s where your object will come in when you 
create a new one 

▪ We want to create our new object at the end of paddle handle 
▪ Select the face at the bottom > Shift + S > Cursor to Selected 

• The cursor is now in the center of our face 
• Make sure not to accidentally click somewhere else 

o Press “Tab” and go into Object mode 
▪ Press Shift + A and click the Empty > Sphere 

• On the left, we’re going to adjust the radius of our empty to 0.1 
▪ Double-click on the Empty on the right in the object manager and type “origin” 

o Let’s label our paddle too; change “circle” to “paddle” 
o We’re going to place our paddle and our origin into a new null 

▪ With our cursor still at the bottom of our handle, press Shift + A > Empty > Plain Axes 
• Change the radius (on the left) to 0.3 

▪ Rename our new Empty “paddle_CTRL” 
▪ Click and drag the paddle and origin icons into the paddle_CTRL to make them children 

• It won’t work if you don’t select the icon 
▪ Doing this allows us to select the paddle_CTRL and move the paddle and origin too 

• Press “G” to test this out 
o Right-click to put the paddle back in its place 
o If you accidentally click somewhere else, press Ctrl + Z 

o Right-click on our paddle and enable our Simple Deformer again by clicking the eye 
o Click under Axis, Origin and select “origin” 
o Click on the “origin” null and rotate it 90 degrees in the X-Axis and Z-Axis 

▪ Now we should be set up properly 
o Right-click on the object and in the deformer, go to where it says Deform 

▪ Move the Angle from left to right and you can see our paddle bending 
• Animating the Paddle Hit 

o In the upper-left, go to our Animation layout 

 
▪ This gives us more tools to play with 

o In the bottom-left, we’re going to change our start frame to “0” and our end frame to “34” 
o Let’s hover over our timeline and hit “Home” and it will zoom in on our frames 

▪ Test “Home” over the Dope sheet and F-curve as well (can always hit it after setting all the keys) 
o We’re going to be animating the Angle value of our bend deformer so make sure that your paddle is 

selected 
o Go to frame 0 

▪ Change the Angle to -35 (make sure you click the wrench) 
▪ You can either right-click on the Angle field and choose Insert Keyframe or you can press “I” as a 

shortcut 
• You have to hover over the Angle field when you’re pressing “I” 

o Go to frame 6 
▪ Change the Angle to 35 
▪ Press “I” 

o Go to frame 17 
▪ Press “I” 

o Go to frame 23 
▪ Change the Angle to -35 
▪ Press “I” 

o Go to frame 34 
▪ Press “I” 

o You can press play to see what we have so far 



• Animating the Paddle Spin 
o Now we’re going to animate our paddle_CTRL so select that 

▪ Do not put these keyframes on the paddle itself 
o Go to frame 6 

▪ Right-click on the Y Rotation and select “Insert Single Keyframe” 
• We don’t want to press “I” right now because this sets a keyframe on XY and Z and we 

don’t need all of those keyframes 
o Go to frame 17 

▪ Change the Y Rotation to 180 
▪ Now, if we hit “I”, it’ll set a single keyframe 

o Go to frame 22 
▪ Press “I” 

o Go to frame 34 
▪ Set the Y Rotation to 360 
▪ Press I 

• Editing the Curves 
o In the lower-left, we have our F-Curve editor 

▪ If we press “N”, more options come up 
o Click on our key at frame 6 and scroll down to the Right Handle 

▪ Click in the “X” field and after your number add “+ 5” then press “Enter” 
o Click our key at frame 22 and do the same thing 

▪ Make sure you pay attention to see that it’s affecting the right key 
o Now our timing looks different and we have a slower start 

• Create and Animate Ping Pong Ball 
o Press “Shift + C” so that the cursor goes to the origin of our viewport 
o Press “Shift + A” > Mesh > UV Sphere 
o Move our ball up a bit in the Z-Axis 
o On the right, reduce the scale to 0.18 for X, Y, and Z 
o On the left, with our sphere selected, under Shading, click Smooth to smooth our ball out 
o “Numpad 3” to go to the side view (“Numpad 5” if your view isn’t orthographic) 
o Go to frame 6 and place your ball so that it is right above your paddle 

▪ On the Z of the Location, right-click and select “Insert Single Keyframe” 
o Got to frame 15 and change the Z location to 3.5 and press “I” 
o In our Dope Sheet in the upper-left, we’re going to right-click on our first keyframe and press “Ctrl + C” 

to copy it 
▪ Go to frame 23 and “Ctrl + V” to paste it 

o In the lower-left, in our F-Curve editor, we’re going to press “Home” to see all of our keys 
▪ Select (right-click) our first keyframe and press “S”, then “0” and “Enter” to make the curve flat 
▪ Do the same for our last keyframe 
▪ Right-click our top keyframe and press “S” and scale your handles up until your right handle says 

about 21 
o It’s currently, one movement and we need the keys to loop to the left and to the right 

▪ Go to the Modifiers tab and click “Add Modifier” 
• Select Cycles 

▪ Now, if you hit play, our ball is constantly going up and down 
• Setting Up Our Camera 

o Go back to our Default layout 

 
o Press “Numpad 0” to view through your camera 
o Press “N” to bring up some options 

▪ Check “Lock Camera to View” 
o We want our camera view to be square, so click the camera over on the right to go into the render 

settings 



▪ Under Dimensions, change the Resolution to 500 by 500 in the X and Y 
▪ Change the 50% to 100% 

o Go to your Timeline and press “Home” 
▪ Go to frame 16 and set your camera angle to how you like it 

• We’re at frame 16 because that’s where the ball is at its highest and we need to make 
sure that it’s in frame 

o Press play to see what it looks like and adjust if you need to 
• Texturing Our Ball 

o If you press “Shift + Z”, you’ll see that our ball is not textured properly 
o Right-click to select our ball, click the checkerboard sphere on the right to go into the Material Editor 

▪ Don’t click “New” 
• We already have the material we’re going to use 

▪ Click the two up and down triangles next to the checkerboard sphere and then choose “yellow” 
for your ball color 

• Animate Our Background 
o Let’s create our second view again 

▪ Go to the type right of our viewport to the diagonal lines and drag it over 
o Click the cube in the lower-left of our viewport and choose UV/Image Editor 
o We’re going to click the folder and open our COLORS.jpg image again 
o Click the world icon on the right 
o Click on the Horizon color and select the eyedropper 

▪ Choose the light blue background 
o Go to frame 6 

▪ Hover over the Horizon color and press “I” to insert a keyframe 
o Go to frame 7 

▪ Click on the Horizon color, select the eyedropper and change the color to purple 
▪ Hover over the Horizon color and press “I” to insert a keyframe 

o Go to frame 23 
▪ Hover over the Horizon color and press “I” to insert a keyframe 

o Go to frame 24 
▪ Click the Horizon color, select the eyedropper and change the color back to light blue 
▪ Hover over the Horizon color and press “I” to insert a keyframe 

• Render Our Animation 
o Get rid of our extra window like we did before 

▪ Click the diagonal lines in the upper-right and drag it over until you see the faint arrow, then let 
go 

o Click on the camera on the right to go to our render settings 
o Under Frame Range, make sure your Start Frame is 0 and your End Frame is 34 

▪ Your Frame Step should be 1 
▪ Close up the Dimensions tab 

o Go down to Output and select where you want your animation to save to 
▪ In the empty field before the location field, type “pingPong_animation” 
▪ The Desktop is a good place to save our file 

• Navigate to the Desktop and press Accept to set the location 
o Typically, when you’re rendering out animation sequences, we use image sequences, but since our 

animation is so simple, we can just render out to a video 
o Where it says PNG, go to H.264 
o Under Encoding, change the Format to MPEG-4 
o When you have everything set, go to the Render dropdown, click Animation and go to the Desktop to 

play your movie 
 


